depot/nix/pkgs/alertmanager-discord.nix

31 lines
793 B
Nix

# SPDX-FileCopyrightText: 2020 Luke Granger-Brown <depot@lukegb.com>
#
# SPDX-License-Identifier: Apache-2.0
{ fetchFromGitHub
, buildGoModule
, lib
}:
let
version = "unstable-20220812";
src = fetchFromGitHub {
owner = "benjojo";
repo = "alertmanager-discord";
rev = "89ef841a7ef43c5520df49d0c28335d899230eb9";
hash = "sha256-6P90c3ECUtmXxr2b0/yVscSI/bBgpXkrhou7Cne/bEM=";
};
in
buildGoModule rec {
pname = "alertmanager-discord";
inherit version src;
goPackagePath = "github.com/benjojo/alertmanager-discord";
vendorHash = null;
meta = with lib; {
homepage = "https://github.com/benjojo/alertmanager-discord";
description = "Alertmanager Discord Webhook bridge";
license = licenses.unfree;
maintainers = with maintainers; [ lukegb ];
};
}