depot/ops/nixos/lib/rexxar-distributed.nix

23 lines
615 B
Nix

# SPDX-FileCopyrightText: 2020 Luke Granger-Brown <depot@lukegb.com>
#
# SPDX-License-Identifier: Apache-2.0
{ lib, config, ... }:
{
nix.buildMachines = lib.mkAfter [ {
hostName = "rexxar";
system = "x86_64-linux";
maxJobs = 64;
speedFactor = 12;
supportedFeatures = [ "nixos-test" "benchmark" "big-parallel" "kvm" ];
mandatoryFeatures = [ ];
} {
hostName = "rexxar";
system = "aarch64-linux";
maxJobs = 64;
speedFactor = 12;
supportedFeatures = [ "nixos-test" "benchmark" "big-parallel" "kvm" ];
mandatoryFeatures = [ ];
}];
nix.distributedBuilds = true;
}