depot/third_party/home-manager/tests/modules/files/source-with-spaces.nix

16 lines
370 B
Nix

{ ... }:
{
home.file."source with spaces!".source = ./. + "/source with spaces!";
nmt.script = ''
assertFileExists 'home-files/source with spaces!';
assertFileContent 'home-files/source with spaces!' \
${
builtins.path {
path = ./. + "/source with spaces!";
name = "source-with-spaces-expected";
}
}
'';
}