a291c8690a
GitOrigin-RevId: e6e19f3d81a982a62e1bba08f0b4f7fdc21b4ea0
23 lines
521 B
Nix
23 lines
521 B
Nix
let
|
|
depot = import ../../../. { };
|
|
inherit (depot) third_party;
|
|
pkgs = third_party.nixpkgs;
|
|
in
|
|
|
|
(pkgs.haskell.packages.ghc8107.extend (pkgs.haskell.lib.packageSourceOverrides {
|
|
xanthous = third_party.gitignoreSource ./.;
|
|
})).shellFor {
|
|
packages = p: [ p.xanthous ];
|
|
withHoogle = true;
|
|
doBenchmark = true;
|
|
buildInputs = (with pkgs.haskell.packages.ghc8107; [
|
|
cabal-install
|
|
ghc-prof-flamegraph
|
|
hp2pretty
|
|
hlint
|
|
haskell-language-server
|
|
cabal2nix
|
|
]) ++ (with pkgs; [
|
|
qpdf
|
|
]);
|
|
}
|