Luke Granger-Brown
6522ddba8c
sapi sapi sapi http://totoro:11316/sam?text=OLE%20Apartments%20are%20Very%20Complicated%20and%20cannot%20be%20understood%20by%20Mere%20Mortals.
27 lines
744 B
Nix
27 lines
744 B
Nix
# SPDX-FileCopyrightText: 2020 Luke Granger-Brown <depot@lukegb.com>
|
|
#
|
|
# SPDX-License-Identifier: Apache-2.0
|
|
|
|
{ depot, pkgs, ... }@args:
|
|
{
|
|
int = pkgs.copyPathToStore ./int;
|
|
logged-out-int = pkgs.copyPathToStore ./logged-out-int;
|
|
quotes = import ./quotes args;
|
|
fup = import ./fup args;
|
|
as205479 = hostName: pkgs.runCommand "as205479-web" {
|
|
inherit hostName;
|
|
depotVersion = depot.version;
|
|
} ''
|
|
cp -Rv ${./as205479} $out
|
|
chmod -R +w $out
|
|
|
|
find $out -name '*.html' | while read filename; do
|
|
substituteInPlace "$filename" \
|
|
--replace "{{NODENAME}}" "$hostName" \
|
|
--replace "{{DEPOT_VERSION}}" "$depotVersion"
|
|
done
|
|
'';
|
|
|
|
lukegbcom = import ./lukegbcom args;
|
|
barf = import ./barf args;
|
|
}
|